Aprender a programar sentencias condicionales

Vamos a ver como usar las sentencias condicionales podremos usar las operaciones lógicas que vimos en el post anterior.
Vamos a ver como usar las sentencias condicionales podremos usar las operaciones lógicas que vimos en el post anterior.

Vamos a ver como usar las sentencias condicionales podremos usar las operaciones lógicas que vimos en el post anterior.

Contenido Relacionado

Sentencia SI (If)

La sentencia si en el pseudocodigo nos permita realizar ciertas acciones de acuerdo al valor de su condición, en otras palabras si tal cosa cumple la condición (True) entonces se ejecutara un bloque de codigo. Tal vez sea más claro usando un ejemplo.

Algoritmo condicionales
	estaHabilitado = Verdadero
	Si estaHabilitado Entonces
                // Aqui empieza el bloque de codigo dentro de if
		Mostrar "Está Habilitado"
                //Aqui puede continuar o terminar sin mas el bloque de codigo
	FinSi
FinAlgoritmo

Como lo vemos la sentencia empieza con la línea Si [condicion] Entonces que indica que para poder ejecutar la línea que tiene dentro se debe cumplir esa sentencia es decir estaHabilitado tiene que ser Verdadero (true) y se termina la sentencia con un FinSi.
Si lo ejecutamos no taremos que nos muestra Está Habilitado, ya que nuestra variable cumple con la condición, pero que pasa si cambiamos el valor de la variable por Falso (false), al ejecutarlo notaremos que no está mostrando el mensaje por pantalla, ya que ahora no estamos cumpliendo con la condición.

Diagrama de flujo sentencias condicionales

Usando sentencia SiNo (else)

Este complemento de la sentencia Si nos permitirá que en el caso que no se cumpla la condición poder ejecutar otro bloque de código opcional.
Y se usa de esta manera.

Algoritmo condicionales
	estaHabilitado = Falso
	Si estaHabilitado Entonces
		Mostrar "Está Habilitado"
	SiNo
		Mostrar "No Está Habilitado"
	FinSi
FinAlgoritmo

Ahora si lo notamos sea Verdadero o sea Falso nos devolverá algún tipo de información, en el caso de este ejemplo nos devolverá No Está Habilitado.

Cabe aclarar que en la parte de la condición se puede usar cualquier tipo de operación lógica como las operaciones Y(and), O(or) y las operaciones comparativas menor que (<), menor e igual que (<=) etc.

Algoritmo condicionales
	edad = 15
	Si edad >= 18 Entonces
		Mostrar "Esta Habilitado"
	SiNo
		Mostrar "No Esta Habilitado"
	FinSi
FinAlgoritmo

Sentencia Segun (Switch)

Esta sentencia es casi nada similar a la anterior, ya que con esta sentencia tendremos un valor y opciones las cuales verificaran si el valor es igual a alguna opción y dentro de esta opción tendremos nuestro bloque de código, lo veremos con un ejemplo.

Algoritmo sin_titulo
	nombre = "Hernan"
	Segun nombre hacer
		"Hernan":
			Mostrar "El nombre es Hernan"
		"Pedro":
			Mostrar "El nombre es Pedro"
	FinSegun
FinAlgoritmo

Con esta sentencia podemos tener diferentes escenarios usualmente se usará para programar un menú que determinará que acción tiene que continuar ejecutando el programa.

Resumen sobre las sentencias condicionales

Podemos usar estas sentencias para hacer que nuestro programa ejecute cierto bloque de código de a cuerdo a ciertos valores u operaciones lógicas.
Esto ya nos va a ayudar para que nuestro programa tome ciertas decisiones esperadas para un usuario.